Jumpcloud Security Incident
Incident Report for Small Exchange Public Status
Resolved
This incident has been resolved.
Posted Jul 19, 2023 - 14:17 CDT
Investigating
Notice Date: July 19, 2023
To: Small Exchange Participants
Notice Number: MN-2023-009
Subject: Jumpcloud Security Incident

We are aware of a security incident involving JumpCloud, a tool used by numerous companies to manage their technology stack. According to JumpCloud, a nation-state sponsored threat actor gained unauthorized access to their systems during June 2023, targeting a small and specific set of their customers.

It is confirmed with JumpCloud that the Exchange is not one of those impacted customers. The Exchange has also confirmed there are no services affected by this through an analysis of the indicators of compromise provided by JumpCloud on July 12, 2023.

The Small Exchange will continue to monitor and communicate with our service providers and customers any updates as they become available.

Please contact the IT Operations group to share information or if you have any questions.

Small Exchange IT Operations
it-ops@thesmallexchange.com
Posted Jul 19, 2023 - 14:17 CDT